MODX Community

Everything is set up correctly, but the FURL still gives a 404 error

MODX REVO
Apache server
I’m trying to set up FURLs on the website, I made all the system settings according to the manual, I choose frozen links, I seem to fix the .htaccess file in the root directory, but anyway, when I try to follow a link like mysite.com/about, a page with a 404 error comes out.
I’m using <base href="[[++site_url]]" /> in header too. And .htaccess in the root directory looks like:

Options +FollowSymlinks
RewriteEngine On
RewriteBase /

# Prevent dot directories (hidden directories like .git) to be exposed to the public
# Except for the .well-known directory used by LetsEncrypt a.o
RewriteRule "/\.|^\.(?!well-known/)" - [F]

# Rewrite www.example.com -> example.com -- used with SEO Strict URLs plugin
RewriteCond %{HTTP_HOST} .
RewriteCond %{HTTP_HOST} ^www.(.*)$ [NC]
RewriteRule ^(.*)$ https://%1/$1 [R=301,L]

# The Friendly URLs part

RewriteCond %{REQUEST_URI} \.html$
RewriteRule ^(.*)\.html$ $1 [R=301,L]

RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ index.php?q=$1 [L,QSA]

Moreover, the links themselves are generated, because everywhere on the site the links are indicated in the format <a href="[[~4]]">, and when you click in the menu on the main page, the transition goes to the https://mysite/about, which again gives 404 error.
Moreover, if you manually enter the address https://mysite/index.php?id=4, then the page I need opens. And when you go from the “resources” tab in the admin panel, you still get to the 404 page.

The brain is already boiling, tell me where to look for the problem. I think there are problems with .htaccess, but what is wrong I don’t understand. Maybe it should not be changed at the root, but somewhere else? HELP!

Is your web server set to read .htaccess files? Is AllowOverride All set for your vhost?

By the way, could there be a problem with the ssl certificate?

I try to add Redirect /test https://community.modx.com/ in my .htaccess file and redirection from https://mysite/test to https://community.modx.com/ is worked. So I think, my web server set up correctly…

Change the base href to this (with the exclamation point):

<base href="[[!++site_url]]" />

Otherwise, your fixes may not take effect.

Change your .htaccess to be as follows to rule out any SSL misconfiguration

Options +FollowSymlinks
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_URI} \.html$
RewriteRule ^(.*)\.html$ $1 [R=301,L]

RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ index.php?q=$1 [L,QSA]

Make sure there’s no index.html file in the root directory.

I’d suggest leaving this section out for now:

RewriteCond %{REQUEST_URI} \.html$
RewriteRule ^(.*)\.html$ $1 [R=301,L]

Double-check the friendly_urls System Setting.

There is only index.php in the rood directory
The friendly_urls System Settings - on the picture. Да = Yes, Нет = No

It seems to work … Thank you, you helped me a lot!

Thank you, just in case I changed it too.