Desanitize TV Text contents

I have built a site which is made up of a number of domains. Seperate domains are pulling in content from the main domain most of the time with some requiring there own. In order to ensure that content is only being update in one place I am using calls such as[[pdoField? &id=74 &field=SectA-WelcomeCopy-Header]] to ensure content is the same across field. This is being place into Text TV’s. Occasionaly the pdoField call gets turned into [[pdoField? &&&id=74 &field=SectA-WelcomeCopy-Header]] which means that the call does not get processed correctly. I appreciate the sanitizing of text and would normally be happy with this. In this instance it is a little pain as I have to keep on reseting the Text Tv’s everytime I do a save on the resource.

Does anybody have tips on how I can resolve this? Perhaps switch off the Text TV sanitizing. Could not find a setting for this.

Many thanks in advance.

is this a richtext - TV?
Then its the RTE, which does its thing.

you can try to use fastField - tags
fastField - fastField | MODX Documentation

Thanks @bruno17. No the fields are just straight Text or Textarea. Great suggestion of using fastField. Not sure why I did not use these instead of PDOfield. Perfect solution. Once again thanks.

This topic was automatically closed 2 days after discussion ended and a solution was marked. New replies are no longer allowed. You can open a new topic by clicking the link icon below the original post or solution and selecting “+ New Topic”.