Database backup for a new modx installation

Good evening. Guys, help me figure it out.
On the naked revo , backup the database : 1. the manager issues a Page unavailable, 2. issues a Page unavailable [php7:error] [pid 1006947] [client] Fatal PHP error: require_once(): Requires failed opening ‘/public_html/core/components/upgrademodx/model/upgrademodx/upgrademodx.class.php ’ (include_path=’.:/usr/share/php7:/usr/share/php’) in /public_html/core/cache/includes/elements/modsnippet/1.include.cache.php in line 74 , 3. the line in the file is require_once($corePath . 'model/upgrademodx/upgrademodx.class.php ');

Your new installation is probably missing the extra UpgradeMODX.

If the dashboard widget is the issue, you can try deleting the widget from the dashboard by deleting the row in the database table modx_dashboard_widget_placement. (Check the database table modx_dashboard_widget to get the ID of the widget.)

Maybe you can also go directly to the “Installer” page in the manager ( and install the missing extra.

It turned out to log in , but failed not to delete, not to reinstall. I can’t log in now /manager/?a=workspaces / When I try to log in, the page is unavailable/

modx_dashboard_widget_placement. deleted it . but I can’t log in either

more errors appeared

/core/model/modx/modelement.class.php on line 567

                     'contextKey' => $contextKey,
                     'options' => $options

Maybe you can try this:

In the database table modx_site_plugins set the column “disabled” to 1 for all the rows to disable all the plugins.

Then clear the cache directory core/cache and check, if it is now possible to log in to the manager.

Hello. Set the source -1 column . I can’t log in

Why the “source” column??

Like I said, to disable a plugin you have to change the column with the name “disabled”.

I was able to log in using /manager/?a=workspaces, what should I do to get started? By /manager logged in , entered a username and password - The page is unavailable

Maybe you could try installing all the extras that were installed on the previous installation.

It’s weird that you can’t log in to the manager start page. With the dashboard-widgets removed and the plugins disabled, I don’t see what else could cause an error.

Of course, I understood that I needed to install them. Before contacting here, I tried, but I can’t reinstall, uninstall and download accordingly - it shows that they are already installed

now in the error_log file I see /core/model/modx/modelement.class.php on line 296

line $this->xpdo->parser->setProcessingElement(true);

 public function process($properties= null, $content= null) {
        if ($this->xpdo->getDebug() === true) $this->xpdo->log(xPDO::LOG_LEVEL_DEBUG, "Processing Element: " . $this->get('name') . ($this->_tag ? "\nTag: {$this->_tag}" : "\n") . "\nProperties: " . print_r($this->_properties, true));
        if ($this->isCacheable() && isset ($this->xpdo->elementCache[$this->_tag])) {
            $this->_output = $this->xpdo->elementCache[$this->_tag];
            $this->_processed = true;
        } else {
            $this->getContent(is_string($content) ? array('content' => $content) : array());
        return $this->_result;

I want to express my gratitude to you. modx revo is new to me, I can say I started to delve into it from the moment I turned here. You always give answers. Do not judge strictly, I am a webmaster, not a programmer

I don’t know what the correct way to proceed is.

I never tried to create a running installation only with a database backup.
You should always backup the database and the files to be able to easily restore it.

The problem is, that the information for MODX extras is stored partly on the disk (paths core\components\extra_name and assets\components\extra_name) and partly in the database (snippets, chunks, plugins, etc.)

When you install a MODX extra, the transport package is stored in core/packages (filename = * With a new MODX installation, these package-files are missing.

You could try downloading these transport-package-files manually and putting them in the folder core/packages or alternatively remove the packages in the manager, so that you can download them again.
(Btw. The information for the packages is stored in the database table modx_transport_packages.)

Make sure to install the same versions of the extras you used before.

Hello. Yes, of course there must be files and a database.
There is such a situation that there are no backups of files

It should theoretically be possible to create a functioning MODX installation with only a database backup. But I don’t know what the best approach is.

Basically what you are missing are all the files from the extras in core/components/ and assets/components/.

Maybe reinstalling all the extras is the correct way. But I don’t know, if that overwrites stuff in the database.

Another way could be to create a new installation where you install all the extras and then copy the folders core/components/ and assets/components/.

Now I’m doing packages. Downloaded everything from , but not from another supplier yet. Download only via Extras from the control panel. And permanently /manager is unavailable. entering by ?a=workspaces

about the second method. I don’t have any site files. only the base. I can’t solve the 500 error. why does it come in and then not. I do not understand

and what if you install a new modx installation with an empty database. install packages and then download the database?