Dasboard main section not showing up in MODX versions up to 2.7.1

I’m trying to udgrade some older MODX installations I have, these are in versions 2.6.5 - 2.7.1, and am finding that although the Manager loads and everything seemingly works, the main section of the home Dashboard doesn’t display. This is happening with several installations. Anything that is 2.7.2 or later is fine.

I have been having some other issues with MODX since this server was ugraded about a week ago, all relating to mod_sec rules and calls to external sources, so I was wondering if there was a change in the way the Dashboard page called the “News” and “Security Updates” feeds between 2.7.1 and 2.7.2 that could be the cause of this? Or is there any other cause that anyone has experienced?

Many thanks - Mark

MODX 2.6.5 - 2.7.1
Apache 2.4.51
PHP 7.4.23
MySQL 8.0.26

Maybe this is the relevant change:

So you upgraded to a newer version, and the problem you were having is resolved? Perfect! :slight_smile:

As you’re running a recent(-ish) version of PHP with an old(-ish) version of MODX, chances are that combination has issues (eg deprecation notices) that have been long fixed.

I’d encourage upgrading to 2.8 while you’re at it, and if you encounter any dashboard issues there we’re happy to help you debug those, starting with looking at the developer console in the browser and looking through the relevant logs (MODX, server). Doing that for an issue in 2.7.1 that’s no longer present in 2.7.2 seems a waste of time, though.

No, alas not. I havent upgraded as the “MODX Upgrade” link shows up in the part of the Dashboard that isn’t displaying, so I haven’t been able to use it. The “UpgradeMODX” resource that is supposed to be for this use case doesn’t seem to work.

Most of my client’s sites are on 2.8.3, but I have a few that have not been touched since the big hacking issue a few years ago that needed the upgrade to 2.6.5, and are still on that version, clients that didn’t want any maintenance with their sites but have resurfaced wanting updates etc. recently. So my first step with any new work was to update to the latest MODX version, which is where I am now.

Is the problem that the “UpgradeMODX” dashboard widget doesn’t work or that you can’t see any widgets in the dashboard at all?

Maybe you can set the system settings feed_modx_news_enabled and feed_modx_security_enabled to No or alternatively remove all other widgets from your dashboard (in the top menu → cogwheel icon → Dashboards → right click “Update Dashboard” → right click “Remove Widget from Dashboard”)


And you can always do a manual upgrade:

https://docs.modx.com/current/en/getting-started/maintenance/upgrading

The two feeds mentioned by halftrainedharry are common culprits in missing manager widgets. Disabling them is one solution, but moving them to the bottom of the dashboard can also help (By changing their rank to 99 in the widget table in the DB if necessary).

Another common problem I’ve seen is a leftover cookie from a previous install. If visiting the site with your browser in incognito or private mode solves the problem, that’s the cause.

Thanks all for your input.

After expending quite a bit of time exploring possible mod_sec issues and PHP version issues and still not solving the issue, I decided it was easier to copy all the templates, chunks, etc. to a Text Wrangler file, do a new installation and copy the stuff back, as this isn’t a very big site.

At least this way it was a predictable amount of time to being up and running rather than chasing the “ghost in the machine” for an unknown amount of time.

Thanks again.

Are you loading the manager at a secure address? I found that the old feed links were to non-secure addresses (‘http://’), and changing them to “https://” solved this problem for me.