Custom tables not showing data in MIGX Management

I created a custom table in MODX 3.0.3 with MIGX, everything worked as expected.

The following snippet works normally, prints all the data in the DB.

$all = $modx->getCollection('History\Model\Drzave');
foreach($all as $c) {
    echo $c->get('naziv');

I tried putting that inside a MIGX Management, but for some reason there is no data shown in the table. Adding a new entry works, adds it to the DB normally. There are no connector errrors, it returns 0 results.

MODX log shows the following errors:

[2023-10-04 13:48:00] (ERROR @ /var/www/sites/dev/core/vendor/xpdo/xpdo/src/xPDO/xPDO.php : 1643) Could not load class 
[2023-10-04 13:48:00] (ERROR @ /var/www/sites/dev/core/vendor/xpdo/xpdo/src/xPDO/xPDO.php : 607) No class specified for loadClass
[2023-10-04 13:48:00] (ERROR @ /var/www/sites/dev/core/vendor/xpdo/xpdo/src/xPDO/xPDO.php : 607) No class specified for loadClass
[2023-10-04 13:48:00] (ERROR @ /var/www/sites/dev/core/vendor/xpdo/xpdo/src/xPDO/xPDO.php : 787) ::getSelectColumns() is not a valid static method.

When I was creating my MIGX table, it found all the fields successfully as well.

Is there anything else I can try? Changing package / class names doesn’t help as well.

What exactly do you mean by “inside a MIGX Management”? Did you create a custom manager page (CMP) and there is no data in the grid?

What versions of MIGX and PHP are you using?
Can you share the MIGX configuration (Right-click → “Export/Import” → Copy the JSON from the field) and the database schema?

Exactly. I have a menu entry that links to


where correct titles/buttons are shown, but the grid says “No items found”.

MIGX is latest: 3.0.2-beta1, PHP 8.1.20

MIGX Config

There seems to be a problem with the “toggletrash” functionality in MODX 3.
If you disable the Actionbutton “toggletrash”, the getlist processor should work.
I try if I can make a pull request to fix the issue.


I must have tried everything … never thought this could be the case :slight_smile: Thanks!
Does “toggletrash” use the “deleted” field in the DB, or is that defined by something else?

Yes it does. But the current processor code creates a wrong SQL query (that then always returns nothing).

1 Like

This topic was automatically closed 2 days after discussion ended and a solution was marked. New replies are no longer allowed. You can open a new topic by clicking the link icon below the original post or solution and selecting “+ New Topic”.