Creating a Fred Editor user

Could someone please explain in a bit more detail how to set up a user with permission to edit content using Fred, without accessing all of the settings in MODX Manager?

I’ve read the documentation at but don’t quite make sense of what to do exactly…

Sorry for spamming the forum with all these Fred questions :see_no_evil:

Hi @sketchi,

This can turn really complex and painful if you want more than the base permissions and if you want to play with resource groups. If you just want to do it with base plain permissions, this should be easy.

It is possible to have users that can only access to Fred without Manager access, and also have access to the manager, limiting the user to a set of menus or options, but this requires a lot of work and testing (customization).

You can achieve this by using Access Control lists.

Steps for a simple example:

  • You will need to create a new user group where you will add those new users, and then, edit it (right click over it);
  • then you need to ensure on your Conext Access that you link “Web” with Fred Editor role in order to allow them to edit in the frontend. If you want that same user group to be able to access manager for content editing, assign the “mgr” contect and assign “Content Editor”.

This way you will be able to have a specific group for fred editing and manager access for content editing.

If you need more, privileges than those that I suggested, you can assign a different access policy option or duplicate the one that you want as base template and edit it as per your needs (this can be done on the Access Control Lists, under “Access Policies” menu).


Thanks @jnogueira for trying to help. I still don’t get it to work though :pensive: Perhaps you can tell me what I’m doing wrong?

I want the user to just have access to front-end Fred editing, no Manager access. So this is what I’ve done:

  1. Added a User Group called Fred Editor.
  2. Created a user called “fred”.
  3. Added fred to the User Group Fred Editor.
  4. Edited the User Group Fred Editor and under Context Access added the context web with Minimum Role set to Super User and Access Policy Fred Editor.
  5. Flushed permissions.

When I log out of Manager and log in as fred I get the error Access denied. If I reload the front-end of the site I don’t see the Fred editor.

What am I missing?

Your permissions on the minimum role need to be set for the role you created, setting an authority of 9000 (as an example).
And you are missing the login plugin on your website :slight_smile:
You will not be able to login on to manager because you don’t have the mgr key assigned to the user.

So you will only be able to achieve what you expect by installing Login extra and perform a simple integration with the frontend.

Right, so I have now:

  1. Installed Login and set up a basic login structure in accordance with (except the Members Home Page step)
  2. I’ve added a Role called Fred Editor with authority 9000.
  3. I’ve edited the User Group Fred Editor and changed the Context Access Minimum Role to Fred Editor 9000 (instad of Super User 0).

I log in as fred on the new login page I’ve created and go to the front-end of the site but I still don’t see the Fred Editor :sweat:

Ok I will check my setup tomorrow to see if I forgot about something. I’ll ping you again as soon as I am able to check this for you.


Thanks v much @jnogueira, appreciate it :pray:

OK, I belive I found the issue: forgot to ask you to clear cache and flush user permissions;

Anyway I replicated the action this way:

  1. Create the User Group on the Access Control lists:
  2. Create the user role with authority set as 9000
  3. Create the user and assign it to the Fred Editor role under the menu “Access Permissions”, and click on “Add User to Group”:
  4. Go back to the Access Control Lists, click on the “Fred Editors” and this is what you should see:
  5. Right click over it and click on “Update User Group”, and on the “Context Access Tab”, you will see a role that is already assigned. You need to add a new context permission like this:
  6. After saving, this is how it should look:
  7. Click on “Save” and close the User Group editor;
  8. On the “Clear Cache”, “Flush Your Permissions”, and then “Logout all users” (if you are on dev environment);
  9. When going to the frontend, and after login, if login is successfull, you should see fred editor plugin. If you don’t see anything, try to go to the homepage again (reload it), as you might have not configured login extra to redirect you to the home page possibly.

Tested this now on my local dev environment using clean install of Mox 2.7.3 with Latest fred and Fred Base Demo Template, and latest login extra.


Ah, that was it! I had done everything exactly as you described, but in your screenshot of Step 6 I noticed you also have another context permission – “web” with minimum role Member 9999 and access policy Context. That’s what was missing!

Seems to be working now :hugs: Many thanks for your patience! :sunflower:

1 Like

I didn’t mention the web permission with 9999 role, as it is added automatically by the system, sorry.
Glad it is working now :slight_smile:

Cheers and happy Fred diving
Keep safe

I didn’t mention the web permission with 9999 role, as it is added automatically by the system, sorry.

I don’t think it was actually… although it is possible I deleted it the other day when I was trying to get the permissions to work :grin: Main thing is it’s working now :partying_face:

Thank you and dito :pray:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.