Content Blocks broken after transferring to another hosting

Hi y’all,

I’ve used MODX for a long time for my websites and I also use Content Block very much. Recently I’ve transferred my MODX installation to another hosting.

Since then I have this really weird problem, when I try to create an Content Block-Layout everything works fine. But only when I an “select” option to the layout, I cannot save the layout or anything. The same thing applies to editing an existing layout.

Does anyone maybe know how to fix this?


Thanks for your help!

Did you check the file permissions of the file assets/components/contentblocks/connector.php? It’s weird that it returns a 403 error code.

I’ve already tried that, ain’t working :((

I’ve also tried changing my max post size in php. No result

In the developer tools of the browser, can you change to the “Network” tab to check what request returns the 403 error? What is the “action” parameter of this request?

I don’t think “Saving” is the problem here. It looks like one request to the ContentBlocks-connector returns an unexpected result that “breaks” the Javascript.

There is the image! (Also, a lot of requests to connector.php are indeed working. But they have different actions)

Sometimes a firewall runs on the server that blocks certain manager requests (because it erroneously assumes that these requests are malicious.)

Maybe check if there is a firewall running in your hosting environment (and if you can adjust the rules or add exceptions).

When you try to save, do you see an endless progress indicator? That usually indicates a mod_security issue.

Nope, it is saving very quickly tbh. But then the window is not closing when i click “save & close”

It’s quite frustrating but yeah. This was the problem :joy: