MODX Community

Collections page not editable, empty area

Hi, I’m a happy user/web worker using modx so many years from version 0.9x to the current 2.7.2-pl.

Now, for the first time, I have a problem with Collections (used many times before without problems). I created a resource as type “collection” but the area for editing content is empty/not available. Changing the resource type to “document” all is visible an editable. Changing back the type to collection the area is gone.

I emptied the core/cache directory manually, emtied browser cache, modx cache and so on. Nothing helps.

I dont’ know where to begin and what to do.

UPDATE: using the Chrome Developer Tools I got this error in the console:

collections.grid.resources.js:151
Uncaught TypeError: Cannot read property 'bind' of undefined
    at collections.grid.ContainerCollections.wrapRenderer (collections.grid.resources.js:151)
    at collections.grid.ContainerCollections.getColumns (collections.grid.resources.js:163)
    at new collections.grid.ContainerCollections (collections.grid.resources.js:32)
    at Object.create (ext-all.js:21)
    at S.createComponent (ext-all.js:21)
    at S.lookupComponent (ext-all.js:21)
    at S.add (ext-all.js:21)
    at S.<anonymous> (ext-all.js:21)
    at Object.each (ext-base.js:21)
    at S.add (ext-all.js:21)

UPDATE 2: same server, other web site, modx version 2.7.1-pl, same PHP 7.3.11: Collections works fine

System:

  • modx version 2.7.2-pl
  • PHP 7.3.11

Addons:

  • Babel
  • CodeMirror
  • Collections
  • EasyCopyright
  • fastField
  • filetranslit
  • FirstChildRedirect
  • FormIt
  • getDate
  • getResources
  • GoogleSiteMap
  • HTML2Minify
  • If
  • lastModified
  • MIGX
  • pdoTools
  • redirectoid
  • Redirector
  • StageCoach
  • TinyMCE (currently uninstalled, problem persists)
  • translit
  • XRouting

Any help/advice would be wonderful. Thanks.

1 Like

bump

have you tried to save the file with a name and then tried to edit it? can you save at all?

Sorry for the late response, I don’t got any notification.

I created a new resource as a “document”. Then under “Extras” I defined a collection, after that I changed the resource created before from “document” to “collection” and saved it. At this point the right area disappears/is empty. Editing the normal way isn’t possible (no tabs, no buttons no content) but with “quick edit” (don’t know if it’s the correct term because I use the german interface) I can change back the resource to “document”. Now it’s editable the normal way but changing back to collection it hides the right area again.

All other ways creating and managing a collection give the same result.

I work longer on other web sites with modx 2.6.5 and collections without problems, all is fine in creating and editing this pages and child documents. But now I don’t dare to do an update for modx version at this “older” sites. The version of “Collections” is the same in all web packages (3.7.1-pl).

1 Like

I tried this now:

  • an older installation of modx with version 2.6.5 and Collections 3.6.0: works fine
  • updated modx to 2.7.1 and tried with Collections 3.6.0: works fine
  • updated Collections to 3.7.1: works fine with modx 2.7.1
  • updated modx to 2.7.2, tried it with Collections 3.7.1: works fine too!

What’s the difference between a twice updated modx (2.6.5 -> 2.7.1 -> 2.7.2) with current version of Collections and a clean install of modx 2.7.2 where Collections doesn’t work as expected?

UPDATE: installed modx 2.7.1 over 2.7.2 (doesn’t helped) and reinstalled 2.7.2: no changes. Collections doesn’t work, right area empty, JS error in the console. And no JS errors in other sides with various combinations of modx and collections versions.

1 Like

Now tried some back and forth changes.

Last I uninstalled collections, removed all files manually via FTP, cleared the cache in modx, in browser and cleared the core/cache manually via FTP on the server.
After this I reinstalled collections and was wondering why I found my self defined collection view (maybe because it’s saved in database and will not deleted while uninstalling the addon).

Now (because I deleted the standard blog collection view after creating my own view) I exported the blog view from an other site and imported it in my troublesome site, then deleted my own view.

And now I can change a document resource to collection and can see the content, tabs and so on. And the JS error is gone too.

Next step will be creating a new self-defined collection view and I will see if this makes new trouble or not.

1 Like

Of course it was not the solution I’d hoped for. Now I have the same problem like in this thread: Collections children not visible for account

No childrens are visible, the collection says: This resource doesn’t have any children (respectively “Diese Ressource hat keine Unterressourcen.” in German). It doesn’t matter if I’ve created a news child or copied an existing resource into the collection’s document. The document “disappears” and the collections seems empty. Changing the resource from collection to document shows the children in the tree.

In the chrome console are no errors or warnings.

1 Like

Ok its great you got past the first problem, but now we have this new one.

This new one is weird, you are saying the document can’t be saved, or disappears from your tree? Or these aren’t resources in your tree? Not entirely familiar with Collections

If you can’t save the resource, you might want to ask your hoster if there are any errors on their side…any difference in your testing of hosters, with the different versions running fine?

Also pls check your Modx error log for anything useful, or anything at all probably.

Very odd behavior

No no no. I can save all documents and no resources disappears really from the tree. The child documents are invisible in the tree like expected with collections. But they are also invisible in the collection table editing the resource with type collection. The collection table says “This resource doesn’t have any children” but it has!

If the parent resource has type “document” all child resources are visible in the tree as sub-resources. If the parent resource has type “collection” all child resources are invisible in the tree (normal behaviour with collections) and should be visible in the parent documents collection table. But this table is empty and give back the message “This resource doesn’t have any children”.

I can save all resources, every time. And the modx log shows no entries regarding to the problem with collections. Also no error message in the web developer console.

UPDATE: Finally, it seems that it was a consequence of unfortunate circumstances that it did not work. Probably I made a few mistakes in defining the Collections or overlooked some important factors (missing tv_ prefixes and others). This shows that working with Collections is generally not easy, but I was able to solve it for myself in the end.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.