MODX Community

Collection Children List not Showing

I tried to use Collections for the first time by changing an existing container document to a collection and it doesn’t seem to show any of the children resources. It shows a count of the resources, but the table, where I think the resources are supposed to be showing, is empty.

What is causing this, or how do I troubleshoot it?

Can you check if there are any errors in the browser console? It might give some clues.

Most likely there is missing/cached js which hasn’t updated and causing an issue.

  • You could try force clearing browser cache.
  • Logout and login again.
  • Clear MODX cache (worth a shot)

Hope it helps.

There are two errors that seem to appear on any resource I visit.

DevTools failed to load SourceMap: Could not load content for https://DOMAIN/manager/assets/modext/modx.jsgrps-min.js.map: HTTP error: status code 404, net::ERR_HTTP_RESPONSE_CODE_FAILURE

and

DevTools failed to load SourceMap: Could not load content for https://DOMAIN/assets/components/tinymcerte/js/vendor/tinymce/skins/modx/skin.min.css.map: HTTP error: status code 404, net::ERR_HTTP_RESPONSE_CODE_FAILURE

When I go to either of those locations there are no matching .map files, but the /modx.jsgrps-min.js and /skin.min.css files are there.

I don’t think these ‘SourceMap’-errors have any importance.

  • Have you checked the error log in MODX?
  • Do you use the default view “Blog” (in the top menu under ‘Extras’ ->‘Collection views’) or have you created a custom view?
  • When you open the “Network” tab in the developer tools of your browser and then click the ‘refresh’-button (beneath the empty grid) it should make a request to ‘assets/components/collections/connector.php’. Do you see the resource-data in the response?

There were some errors, but nothing new from loading that collection page.

I think I solved the problem, even though I’m not sure what caused it. In the collection settings I had a custom view which I created from scratch. I changed that back to the default and it worked fine. So I duplicated the default blog view and made changes to that which works.

That explains it, the custom view from scratch doesn’t have columns which shows title or anything. So it was empty :smiley:

Glad you figured it out.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.