CKEditor won't update

ModxCloud 3.03, CKEditor 1.4.4

Error log shows these errors:
[2023-08-08 13:14:38] (ERROR in MODX\Revolution\Transport\modTransportProvider::latest @ /www/core/src/Revolution/Transport/modTransportProvider.php : 264) Could not load updates for ckeditor-1.4.4-pl: Package Version Not Found

Check for updates for package shows:

So I tried reinstalling the extra (in a dev cloud) and it installs version 1.4.0 and says ‘No updates available’ when I check - while I had 1.4.4 installed before and I know 1.4.5 is out.

What is wrong with it?

If you look at the page here

you can see that in the section “Supported Versions” it says that only MODX versions < 3.0 are supported.

Supported Versions
2.2 - <3.0

So the API in the MODX manager won’t find a matching package for your MODX version.

This doesn’t (necessarily) mean, that the extra doesn’t work in MODX 3.
Probably the meta data for the package in the package provider is just wrong.

1 Like

Thanks, I never saw that as it always worked fine. I’ll have a look at TinyMCE Rich Text Editor.

This topic was automatically closed 2 days after discussion ended and a solution was marked. New replies are no longer allowed. You can open a new topic by clicking the link icon below the original post or solution and selecting “+ New Topic”.