Changes are not saved

When editing a resource or template, changes are not saved. No problems with editing and saving chunks. I’m running MODX 3.05 and php8.2.
Had no problems after installing and building the site.
Error log is empty.
Does anyone know what could be going on?

Does the Saving dialogue:


complete or does it stay on-screen?

Have you recently updated MODX or added any new Extras?

The dialogue stays on-screen. Problem happened suddenly (client noticed me this morning). Site was running on MODX 3.04. Updating to 3.05 did not solved it.
No new extras were added and all the extras are up to date.

Open the developer tools in the browser and go to the “Network” tab.
Then try to save the resource/template.
MODX should create a new AJAX request.
What is the HTTP response status code of this request? 500?

this wat i see when tryin to save:

and this:

Is it possible that your host has enabled or updated mod_security on your webserver?

In some cases - you can test by adding the following code to your root .htaccess file:

<IfModule mod_security.c>
  SecFilterEngine Off
  SecFilterScanPOST Off

Add the code and try to save again.

Yes, it’s most likely a firewall on the server that interferes.

When you click on the request in the “Network” tab, what is the actual response from the server? (It seems to be HTML instead of the expected JSON response).

YES!. That’s what caused it. Webhost has solved it and everything works fine now.

1 Like

Glad you’re sorted @leo_wolff :+1:

This topic was automatically closed 2 days after discussion ended and a solution was marked. New replies are no longer allowed. You can open a new topic by clicking the link icon below the original post or solution and selecting “+ New Topic”.