Blank Manager with 500 Error

I recently upgraded a site to MODX 2.8.4 (on PHP 7.3) and I now get a blank manager. Looking at the various threads on this topic, I decided to start a new one as I don’t think I found the answer (my apologies if this was solved elsewhere but I couldn’t find an answer).

When I load the manager, my console is giving me these two errors off the bat:

Failed to load resource: the server responded with a status of 500 (Internal Server Error)

Failed to load resource: the server responded with a status of 500 (Internal Server Error) modx.config.js.php:

I checked on these files and they do exist on the server but for some reason, it is returning a 500 error.

I tried the following:

  • turned off compress_js and compress_css in the system settings (using phpmyadmin)
  • accessed the manager with and without www.
  • rerun setup
  • cleared the cache
  • Changed the permissions of lang.js.php and modx.config.js to 755

Any help would be appreciated.


Check your servers’ (PHP/apache) error log for details on the 500 error. Without details you’re just taking random stabs in the dark to figure out the problem.

If you don’t have access to the server error log, ask your host where to find and/or enable it. In some cases, you may also find an error when accessing the file that throws the 500 error directly.

The only thing you haven’t done yet which I’d consider worth checking without a log is the core/config/ file. If that got corrupted during the upgrade (you’ll see things like {database_password} instead of the actual password, restore that file from a pre-upgrade backup.

Also worth noting, does your front-end still work or is that also down?

Thanks Markh.

I looked at the error log provided in Cpanel and I don’t see any recent issues except this:
[Mon Oct 17 13:08:42.192553 2022] [authz_core:error] [pid 74686:tid 47616138696448] [client IP:42484] AH01630: client denied by server configuration: /home/[clientname]/public_html/core/docs/changelog.txt

Yes, the front end still works. The core/config/ seems accurate.

Does anybody else have some experience or insight into this?

Does this only concern the manager start page (manager/) or also all other manager pages (like for example manager/?a=system/settings)?

If you temporarily disable all the plugins (database table modx_site_plugins → column “disabled”) and then clear the cache, does this solve the issue?

If you temporarily clear the system setting “extension_packages” (database table modx_system_settings → key = “extension_packages”) and then clear the cache, does this solve the issue?

Thanks @halftrainedharry for the suggestions. I tried your first two suggestions but no luck.

For the modx_system_settings, I don’t see an entry for extension_packages in the table?

This is normal if the setting isn’t used.

The point of disabling the plugins and checking extension_packages was to make sure, that none of the installed extras causes the error.

As these test were unsuccessful, this implies that the error is probably a core MODX issue. But without an error message it’s impossible to find out what causes the error.