Auth0 + Microsoft Azure AD

Hi all,

I’m trying to add Auth0 login using Sepiariver’s Auth0 extra and so users can login with Microsoft Azure AD.

On the site I added a Microsoft Azure AD connection and I can test and verify that the login works.

But on my login website page I get this error message: “Email verification is required.”
There is no other error in the logs.

This is my snippet:
[[auth0.login? &debug=1 &loginResourceId=122 &requireVerifiedEmail=0 ]]

These are the settings I added:

auth0.audience           https://**********		 
auth0.client_id            Zl8************************		 
auth0.client_secret      ****************************		 
auth0.domain               *********		
auth0.redirect_uri         https://***********/index.php?id=121

redirect_uri is de link to the page were the auth0.login snippet is.

In auth0 - Applications – settings I added the Login and Callback URL: https://***********/index.php?id=121 (= page where the auth0 snippet is.)

In auth0 – Applications – API => Machine to Machine Applications I authorized my application and made sure “read:users update:users read:users_app_metadata update:users_app_metadata” are all checked.

Sidenote: in I also found a different Audience value: https://*********, I tried that too, but didnt work.

I tried to follow the documentation on GitHub - sepiariver/auth0: Auth0 integration for MODX CMS., but now i’m stuck and I dont know where to look or try to change next.

On my webpage the login screen never shows up. I only see a “Email verification is required.” error.

Is there anyone who might see what I’m doing wrong here?

Thanks a lot!