MODX Community

Articles: Saving takes long time, mostly not working

I’ve been working on this problem for a very long time, but didn’t find any solution - even my special friend google couldn’t help.

The basics:

  • modx 2.7.3pl
  • articles 1.7.13-pl
  • tinymce 4.3.4-pl

hosted by strato.de:

  • php 7.2
  • php boost off
  • mysql 5.6

It doesn’t matter if you’re creating a new article or editing an existing one, when trying to save it, it takes a very long time and mostly the changes are not saved. If the changes are really important and need to be released quickly, I edited them in the database.

Needless to say, this is very nerve-wracking.

What I’ve tried so far:

Updating everything, including modx and all extras.

Changing the charset of the database because it’s a german website and includes special chars, such as äöüßÄÖÜ. Of course I changed the settings in modx as well.

Creating a new articles container and an article which was successfully saved. I copied some of the old articles into the new container and everything worked fine. After this short glimpse of hope I edited the database and moved all old articles to the new container - and the problem returned.

I suppose there are some articles crashing or confusing the database as everything is working on a new container. But how can I find them? Needless to say I don’t want to copy every entry by hand. That would be the last desperate solution to get everything working again.

Any ideas?

This could be the result of a mismatch in the DB character set and the MODX character set.

Look at the character set in core/config/config.inc.php. Then look at the DB in PhpMyAdmin. Look at the structure tab and make sure that the charset and collation of the DB, all tables, and all text fields inside the tables match that. If not, see this article.

FYI, Sitecheck will do those checks for you (but it won’t fix anything), though doing it manually is an option.