After creating a new database and setting up 3.0.1, import backup restore from "phpMyAdmin". The login manager is displayed but the site is not displayed

I made a mistake near the completion of the demo site.
I’m not a system engineer, so I thought it would take time to recover from the current situation.
I had a backup, so I thought it would be faster to delete everything and renew it.
I completely deleted the demo site folders and databases and installed modx-3.0.0.
The demo site backup is modx-3.0.1, so I updated modx-3.0.0.
I opened “phpMyAdmin” and imported the backup restore.
I also uploaded a directory containing CSS and Javascript files.

Since the demo site is a subdirectory, I added the following to ht.access.

RewriteEngine On
RewriteBase /subdirectory-name

We also changed the following:

php_flag zlib.output_compression On
php_value zlib.output_compression_level 5

I uploaded ht.access and renamed it to .htaccess.

You logged in from / manager.
There was a message on the dashboard.
Not accurate, but “Rename ht.access in CORE to .htaccess and save”
I followed the message.
All “Documents” and “Elements” have been restored.

I thought this was fine, but I opened the preview from / manager, but it doesn’t appear.

The following message is displayed in the browser.

“This page is not working is currently unable to process this request.

When I checked the error log of the server, I found the following display.

AH00124: Request exceeded the limit of 10 internal redirects due to probable configuration error. Use ‘LimitInternalRecursion’ to increase the limit if necessary. Use ‘LogLevel debug’ to get a backtrace., referer:
[Tue May 03 09:55:12.602163 2022] [autoindex:error] [pid 90145] [client] AH01276: Cannot serve directory /home/xxxxxxxx/www/xxxx/: No matching DirectoryIndex (index.html,index.htm,index.shtml,index.shtm,index.cgi,index.php,index.hdml) found, and server-generated directory index forbidden by Options directive, referer:

I’ve been using HODX Evo so far, but I’ve never experienced it.
I don’t know how to deal with it.

Please help me.
Thank you.

I suspect there is something wrong with your .htaccess file in the root directory.

Thank you for your prompt response.

First, I turned off the friendly URL that was on.
I added # under .htaccess in the root directory to restore the initial state.
php_flag zlib.output_compression On
php_value zlib.output_compression_level 5

It didn’t change, so I unzipped to make it a new .htaccess.
Still, there was no change.

Does it work if you explicitly call the index.php file with the resource-id as the parameter?

The browser is white and nothing is displayed.

Are there any relevant errors in the MODX error log (core/cache/logs/error.log)?

Does the system setting error_page point to a resource that exists and is published?

The following was displayed several times.
There was no other.

[2022-05-03 17:48:53] (ERROR @ /home/xxxxxxxx/www/xxxx/xxx/core/src/Revolution/modDashboardWidget.php : 125) Failed to load dashboard widget with controller title “dashboard”.

I didn’t create an error page.
I will make it now and set it.

Well this error only affects the manager and not the frontend.

I honestly don’t know what the problem could be here.

Maybe try deleting the whole cache directory (core/cache) manually or try running the setup once again (for the same MODX version).

I tried to create a page, but I can’t.
When I try to display the edit page, it changes to the following page.

This page is not working is currently unable to process this request.

I go back to the manager page and click “Edit” from the document you are creating, you will see the above again.

I try setting it up again.
I will write the result after 12 hours, so thank you again.
Thank you for the place busy.

I’m not an engineer, so I can only make decisions by imagination.
I had been using Evo so far. I started using Revo with MODX3.
This backup used “Backup MODX”.
It is said that some packages are not yet compatible with MODX3.
Has anyone backed up using “Backup MODX” from MODX3?
Is it working properly?

I tried various methods I could do, but it didn’t work.
From now on, I will replace everything by self-input.
It was a demo site, so I was saved.
I will not use “buckupMODX” for future backups, will export from “phpMyAdmin”.

Thank you to everyone who helped.

1 Like