MODX Community

After cleaning up my hacked site all links go to "Not Found"

Hi there,
my site has been hacked. I found a lot of files using https://forums.modx.com/thread/94643/how-to-clean-up-your-hacked-webspace and removed them. After cleaning everything up I have access to my starting page, to the manager with all ressources/elements and files, but all links are moving to a 404 “Not found” page. All wayfinder links at the frontend and at the backend I see all entries

but if I click display I just get the Not Found. I thought it’s an FURL problem, cleared the cache, renamed .htaccess to ht.access, disabled FURLS in system settings but the problem’s still existing.

Any idea?

I’m using MODX Revolution 2.7.1-pl

Thank you for your help!

1 Like

does it find and run your index.php?

Yes, it’s finding my index.php, but the navigation links are leading in 404.

so, are you saying wayfinder generates wrong links, or MODX redirects all requests to the Not Found - page?

1 Like

Problem solved.

I deleted all core/cache folders and everything works fine again :grinning: Stupid me!

Thank you!

2 Likes

When in doubt, delete the cache :wink:

Hello, I have the very same problem, but being new to MODX I would like to know better what Core/cache folders/files I can delete safely. All in public>>core>> cache? Thanks

I have the same problem and after deleting all core/cache folders the problem persists! need help.

I deleted everything inside the cache folder. Don’t forget to delete your browser cache as well to control the result.

Bingo! that or something else, but now it is ok!!!