MODX Community

404 Error when accessing website

Hi All

I’m running a Modx 2.7.3 on XAMPP 3.2.2 on my local machine. I’ve also copied the website over to a remote website and been able to set it up thanks to the documentation online.

I’m seeing a peculiar problem and i can’t find any similar cases online.

I’m experiencing 404 errors when trying to access the website (not using FURL’s) just IP address and server directory http://IP_ADDRESS/website_name

But I’m able to access the site as soon as I log into the manager via administrator user. Opening up a new tab and copy pasting above weblink (as above) in the window and the site is perfectly accessible, user can log in.

So the address http://IP_ADDRESS/website_name/manager is accessible all the time. No problems there.

I’m using the Login plugin 1.9,9 for the website itself. So on first accessing website users arrive at the login resource page (in theory).

changing ht.access files in root, manager and core directories to .htaccess does not appear to change symptoms.

So in summary, user able to access the website and login so long as an administrator session is authenticated in the modx manager back end within the same browser on another tab. Otherwise, no administrator session in browser it’s a 404 error.

If anyone has any ideas, thanks in advance.

same symptoms on both local and remote installations. Remote installation is running XAMPP 3.2.4

also seen that website only accessible if following the same address as the manager login session.
Example:
localhost/website_name/manager > trying to access site using 127.0.0.1/website_name does not work. localhost/website_name does work and user able to log in.

Does your system setting site_start point to an existing resource that has been published?

site_start system setting has a value of 1. If that’s linked to a resource it is the Login Page resource. It contains the snippet call as per bellow code. The resource 1 is published.

[[!Login?
&loginTpl=`lgnLoginTpl`
&logoutTpl=`lgnLogoutTpl`
&errTpl=`lgnErrTpl`
&loginResourceId=`9`
&logoutResourceId=`10`
]]

Did you put your resource 1 into a ‘Resource Group’ to restrict the access?

There are 2 resource groups and resource 1 is included in both of them.

That seems to be the cause of your problem. Resource 1 has to be accessible for non-authorized users. How should they authorize themselves, when they have no access to the login page.

Halftrainedharry, you appear to have fixed my problem! I deselected all resource groups. I obviously failed to see your logic when erroneously configuring that.

You were on to it very quickly too

Many thanks for your time. Definitely owe you a beer or two!