MODX Community

URL path to files for context not working

Hello.
I create a new context /es/, everything is working fine (redirection, texts, etc…) but the images that are not loading.

The path for the default context (web) are : url.com/assets/web/images/
But the path for the new context is: url.com/es/assets/web/images/ the /es/ in the path cause a 404 not found.

My Media source settings:

basePath: assets/web/
basePathRelative: No
baseUrl: /assets/web/
baseUrlRelative: No

In Settings - -

rb_base_dir: empty
rb_base_url: empty
strip_image_paths: Yes

There is not way that I can make this work, any help please?
Thanks!

Ps: I don’t want to use .htaccess code, there are going to be changes not made by me in the future adn I don’t want that users needs to change the .htaccess.

1 Like

Try setting basePathRelative and baseUrlRelative to Yes that’s the way my media sources are set up in my multilingual site which works fine.

1 Like

basePathRelative and baseUrlRelative to Yes didn’t work.
I’m using Xrouting, I think the main point here is how in the hell can I get rid of the /base_url/ in the files path for all the context?

Thanks!

1 Like

OK I solve the problem just changinf Xroute for LangRouter
Here the link, instructions are great!

http://jako.github.io/LangRouter/usage/

Thanks Jako for the plugin!

1 Like