MODX Community

Uploading images

Uploading images doesn’t work properly. When uploading an image in the manager, I get the message that the upload was successful. The image seems to be in the right folder. Nevertheless, the images are not uploaded to the server.

The strange thing is, that at first, it worked all fine. Since a week I have this problem. There were no changes on the server nor on the site itself.

Does anyone knows what could be the the problem, or even better, the solution?

Good day @leo_wolff,

What does your environment look like? What version of MODX you running…Apache…

Maybe it’s just a specific folder or set of folders that is having the issues?

Can you check the permissions on whatever folder?

Good day @Mr_JimWest
I’m running the latest version (2.7.3.) on an Apache server.
The permissions of the folders are all set at 0755. Until last week there was no problem at all. There were no changes made om the site nor on the server. That’s what’s bothering me.

Are these files larger that other files you have uploaded. I have run into problems with the upload size before, I just changed the setting in the php.ini.

Yeah, it’s a bit scary @leo_wolff. :worried:

Did you see any errors in the MODX logs or the server’s PHP logs?

Maybe it’s a browser misbehaving. Have you tried a different web browser? Browsers are updating behind out backs all of the time nowadays. :roll_eyes:

Have you tried uploading a very uniquely named file, like “3-26-2020-uploadTest.jpg”, and then trying to find it on the server via search? - Make sure it’s not hiding somewhere?

Hi @Mr_JimWest. I’ve figured it out . I’ve build the site on a sub-domain and then migrated it to production. In the config-file was still one link to the sub-domain. Didn’t see it till now Uploaded images ended up in that sub-domain.
I’ve discovered it by making a search on the server… Thank you for that.

Have a nice weekend and stay healthy.

Problem is solved. Thank you for replying