Upgrading site to MODX 3 fails installation

I made a duplicate of one of my existing sites in 2.8.3 to test upgrading to MODX 3 beta 1.

Observed behavior

The final MODX Install screen takes a VERY long time to complete. On a tiny site that is already in MODX 3, it still takes a long time but finally finishes. When trying to upgrade a more extensive site (still not very large), the final MODX Installer says everything is fine:

    Checking PHP version: OK! Running: 7.3.32

    Checking PHP for zlib dependency: OK!

    Checking for SimpleXML: OK!

    Checking if memory limit is set to at least 24M: OK! Set to 512M

    Checking if sessions are properly configured: OK!

    Checking if .../bcf/core/cache directory exists: OK!

    Checking if .../bcf/core/cache directory is writable: OK!

    Checking if .../bcf/core/export directory exists: OK!

    Checking if /home/rainbowt/bcf/core/export directory is writable: OK!

    Checking if .../bcf/core/packages directory exists: OK!

    Checking if .../bcf/core/packages directory is writable: OK!

    Checking if .../bcf/core/config/config.inc.php exists and is writable: OK!

    Creating connection to the database: OK!

    Checking for suhosin issues:OK!

    Checking if we should disable CSS/JS compression: Not selected, skipping test.

, but after clicking the install button, I wait about two minutes, and then the script times out. “This request takes too long to process, it is timed out by the server.” I increased the php max_execution_time to 6 minutes, but that didn’t help. Why is this step taking so long? Is anyone else having this issue?

On the tiny site already in MODX 3 that I updated, the script does finish, but there are bunch of errors at the top of the next screen about table columns that already exist. Shouldn’t the installation script check for the existence of table columns before trying to add them?

Are there anything in your php error.log ?

What version of PHP are you using ?

No errors. PHP version 7.3.

I am guessing that some plugin you have installed on the site is caught in a loop. Can you try disabling all plugins before running the upgrade?

I turned off Collections and MIGX, and the installer completed. So, it’s one of these two that caused the problem. When I logged in, though, nothing showed up in the Resource tree. I had to completely delete these two plugins to get editing to work. I tried installing the “for 3” branch of Collections, but that just generated a bunch of errors.

There is a release of Collections for 3 now that has some issues but works mostly now.

I went to Collections on Github and downloaded the “for 3” branch, then installed that on my site. Is that the one you are talking about? Or is there somewhere else I didn’t find?

Ah, I see what the issue was. I had to change the class_key for collection containers in the database to “Collections\Model\CollectionContainer”. It’s working now.

1 Like