MODX Community

Upgrade Modx issue

Hi there,

I have just tried to upgrade an ageing site to the latest version of Modx using upgradeModx.
It was running on V 2.6.5 so I just tried to go to V 2.7.0.

It thought about it for a while, then gave me the following screen

When I click ‘back to manager’ i get a 500 error.

I checked and the PHP version is pretty old too - 5.6.

Any advice on how to fix this?

The front end seems to be working fine still.

Thanks!!
Andy

The front end is not working actually - none of the images are loading properly.
I will restore from the backup I took, and start again - but any tips on how to use upgradeModx successfully this time?

Thanks
Andy

Before reverting, can you check your server error log for the reason behind the 500 error?

Thanks Mark.

All I can see is this:
[Wed Jan 15 16:15:06.992510 2020] [access_compat:error] [pid 2575553] [client MY.SER.VER.IP:48622] AH01797: client denied by server configuration: /home/account/public_html/core/docs/changelog.txt

from which version to which version did you upgrade?

Hi Bruno

It was from 2.6.5 > 2.7.0

Is this using the latest version of UpgradeMODX?
Are you using the dashboard widget or the snippet on a resource?
It didn’t take you to the MODX setup?

Hi there,
I just realised that the site was so out of date that the upgradeMODX was also out of date.
I reinstalled the site from backup (which reminded me exactly why i do backups all the time!) and then upgraded The extra, Then upgraded PHP to 7.3, THEN ran the update - all went fine!

Problem solved.
I think it was a problem with PHP and the UpgradeMODX Extra all being out of date perhaps.