Tagger: Troubleshooting missing results

I’m using tagger on my website and this was previously working until now. I’m not sure what the problem is and since the results pages are blank, I’m not sure where to start with troubleshooting it.

I use pdoResources to generate the queries with TaggerGetResources which outputs to a placeholder. Then I use the placeholder with a ‘notempty’ filter to determine which grouping of results to show (i.e. related people, insights, news, etc.).

In pdoResources, I tried using showLog and the SQL query that’s shown is valid and runs fine in phpMyAdmin. It’s just for some reason, not working on the front end of the site.

Any thoughts on where to start?


Hi @jeffsydor
Good to see you in the new forums.

Is there anything in the MODX error log, or the website php error log?

As it was working before can you think what might have changed? Could the hosting company have upgraded the php version?

Could you post your pdoResources snippet and placeholder?

Thanks! I like the new look so far and it’s definitely more responsive. The old one was really slow for me!

There’s nothing showing up in the error log either for MODX or PHP.

I can’t think of what could’ve changed that would’ve caused it since I have no idea when it started not working. But below is a sample of my code.

	&tpl =`@INLINE <div class="result"><a href="{{+uri}}">{{+pagetitle}}</a></div>`
	&select = `{"modResource":"id,pagetitle,uri"}`
	&where=`[[!TaggerGetResourcesWhere? &tags=`[[!#get.tag:stripTags:ucase]]` &where=`"template:IN":[29]`]]`

<div class="category other">
	<h1 class="header">INSIGHTS</h1>
	<div class="results">

try to call the placeholder uncached.
[[!+searchInsights:notempty=` <div class="category other"> <h1 class="header">INSIGHTS</h1> <div class="results"> [[!+searchInsights]] </div> </div>`]]

1 Like

Dude, not only can I get notifications now when a reply is made, but that worked! Thanks!

1 Like

Since your snippet, which produces the placeholder is called uncached, also the placeholder has to be uncached.
There was a change in parsing cached/uncached tags between versions


Thanks Bruno, I never knew that!

This topic was automatically closed 2 days after discussion ended and a solution was marked. New replies are no longer allowed. You can open a new topic by clicking the link icon below the original post or solution and selecting “+ New Topic”.