Strange MODX behaviour!

I don’t think so. That shouldn’t throw a 500 error.

There is nothing that I can deduce from this response. I would need a php error message and the file/line number where the error occurs.

BTW: To post the error messages, please put lines with three back-ticks at the start and at the end of the text to format it. It’s hard to read the message the way it’s formatted now.

```//line with 3 back-ticks at the beginning
//the error message
```//line with 3 back-ticks at the end

Ah Ok - soz about that.
Hmm - ned to try and find a way to get the PHP errors then.
V annoying - I wish I could move it to my server, as it would just work.

One thing I’ve noticed - I check the server info against my own server, and my server has these differences under /?a=system/info

Working server:

Database version: 10.2.40-MariaDB Database version:
PDO drivers: mysql, sqlite
disable_functions: exec,passthru,shell_exec,system
doc_root: /home/user/

Troublesome server:

Database version: 5.6.41-84.1
PDO drivers: mysql, odbc, pgsql
disable_functions: no value
doc_root: no value

I’ve only listed the settings which are different. The doc_root stood out as a potential problem? Does this point to anything?

I noticed that nearly all your server paths refer to the dev subdomain: But there are one or two references to the main domain. Is it possible that there are any cross domain issues or configuration issues related to using the wrong domain/subdomain in any of your configuration files? Have you tried re-running setup?

PS: You have revealed the actual domain name in the last post.

Thanks Andy - have changed that! :wink:
No the inconsistency of domain/sub domain was just me when hiding the real domains. All paths point to the dev sub domain.

I zipped up the site and database, installed it on another server and it works fine.

So something to do with server config but can’t work out what!


When you’re on the Network tab of Dev. Tools, you can click on any line that makes an ajax call to see the request and the response. Often, there’s some messy HTML surrounding a PHP error.

BTW, have you tried putting your browser in Private or Incognito mode? When you upgrade MODX, sometimes a leftover cookie will cause weird effects in the Manager. If this solves your problem, clear your cookies for the site.

Thanks Bob. Private window didn’t help unfortunately. Had already cleared caches and cookies etc.

Couldn’t find anythin int he Network tab that would help - Unfortunately I think I hav to just persuade them to move to a host I know instead - but anoying as I prefer to fix these things rathe than run away!

My MODX-Friendly hosts list. A2 has worked very well for me, though MODX cloud is also a good option.

Thanks Bob - I have a local hosting company here actually who are brilliant ( they never let me down - but this one was bouht my the client 9cheap and not so cheerful!!)