PDO tools not working

Good day,

I am trying to build a repeating list staff members and I’m uncertain why it’s not working. The error log doesn’t spit anything out, and the info that is to be displayed when hovered over the image is instead being shoved underneath the image. The code should be functional as I took it from an old website I developed and it worked on there.

I’m using the addons Collections, getResources, getPHP and they’re all updated. I’m a bit stumped and I could use some ideas on where I done goofed. Thank you in advance

Here’s my code


Here’s what it should look like

And here is what it is displaying (some of the gray lines below are text that should show up in the overlay)

It sounds like it’s an issue with either the chunks used or the css. If you inspect the HTML output of one item on the old site, and one on the new site. what’s the difference? Feel free to post here.

1 Like

Did you forget to enclose the snippet properties in back-ticks, or are they just not showing here?

Also, the &sortby property should have an “else,” though I would make it just pagetitle with no tag until things are working.

1 Like

He enclosed them with backticks, he just didn’t use a codeblock when posting them on the forum. I’ve edited it to show correctly.

1 Like

Check your CSS, if parts are right the chunk is fine I guess. Can you share a link so we can inspect the code?

1 Like

Check that all of the CSS is correct (including the inline style names) and whatever js is driving the display of the hidden text is loaded and working (look at the browser console for any errors).

1 Like

Thanks for the input everyone, I finally had a chance to get under the hood a bit more and I’m following your suggestions.

I have been using the element inspector and just even a base look at it does indeed show that some css isn’t making it over so looks like I’ll have to go through this with a fine tooth comb.I saw some colors change so I think ya’ll were right about CSS not connecting somewhere down the line, I’ll double check my snippets but I think they’re good.

Thank you again to everyone, I FIGURED IT OUT!!! So as the other users had suggested I went through element by element and looked at the CSS to find inconsistencies. I had found some but it still wasn’t displaying right. As a matter of fact, some of the css wasn’t matching up even though it was properly linked. Why? Then I noticed something when I was inspecting elements:


Notice the tr and td spitting out css things? Notice that lessphp.php thingybobber? I did not see it on my new page, only on the old page where it worked.

Thats right. My code worked this whole time BUT for whatever reason my compiler wasn’t behaving right, so I installed the package lessPHP plugin, and boomshakalaka, it worked.

Thank you all for your suggestions.

1 Like

This topic was automatically closed 2 days after discussion ended and a solution was marked. New replies are no longer allowed. You can open a new topic by clicking the link icon below the original post or solution and selecting “+ New Topic”.