"Open in Fred" opens the page but Fred is missing (MODXCloud)


I installed Fred today and its dependencies.
I selected the Fred (Creative One Page Theme) for the 4 pages in my website. Except for the Home page, it removed the content in the content pane.

Step to reproduce

Click on “Open in Fred” button in the document editing pane.

Observed behavior

When I click on “Open in Fred” it open the page in a new window, but there is no Fred UI, just the Home page content. I viewed source and can see that all the HTML is there from the Theme.

Expected behavior

According to the video at https://fred.modx.com/ there’s supposed to be a Fred editing area at the bottom of the page.


MODX Cloud, version 2.71, latest build of Firefox. I’ve tried the same thing in Safari with the same result. Mac Mojave 10.14.4

Do you have any errors in your browser console? When you say all the markup is there from the theme, do you mean you can see the markup for the Fred editor?

I can see the Theme Markup, but there’s no Editor Markup.

Hi @ultrasef … send us a ticket from the Cloud Dashboard and we’ll take a peek for you.