No front end in 2.7.3

Hi @showa26. I’m glad you made progress with the site. I wonder if one or more of these answers solved the initial problem? If so, are you able to mark it as a solution so that others who encounter a similar issue might be able to find the solution?

No not yet. I got an error getresources was missing in core components. I copied it from a backup and now I am getting this error:
/core/xpdo/om/xpdoobject.class.php : 811) modDocument: Attempt to set NOT NULL field template to NULL

This sounds like you may want to start from scratch if you took a backup of the site and db first. Is that possible? What procedure did you follow to upgrade the site? Was it the traditional method of upload, overwrite with newer and running the setup? Or some other method? Did you do it via SSH/FTP? Are your db creds correct? in core/config/ Are there other errors on the server outside of the MODX Error log?

At the moment I am away for a holliday. I will answer when I am back home.

I am back.
I used Bobray’s UpgradeMODX package. Doing this I got some errors. There was no UGM directory and the newer MODX version didn’t download. I put in the directory manually and the upgrades did download. Installing showed an error again. No setup directory. Again after creating this (empty) directory I was able to run the setup. I run all the the advised upgrades, and manager showed the correct upgrade every time. Because I couldn’t go to the front-end I used ftp to upload the zip file 2.7.3 unzipped it on the server and upgrade 2.7.3 again. Db creds seems to be correct, on phpMyAdmin general setting of the charset is utf8_bin looking at the database in phpMyAdmin I see for mysql utf8mb4_unicode_ci for cecilia utf8_general_ci and in the core/config/ file utf_8. I also got a problem with gallery not generating thumbnails gallery/cache is empty and there are no pictures in components gallery, but in files the pictures are visible with thumbnails.

It is probably a problem with the Flexibility 3 template. I installed Flexibility 5 and I am rebuilding the site with the same resources and this seems to function.
Still got the gallery issue. Gallery is doesn’t show thumbnails and pictures, in front and back end.

Hi, if neither the UGM directory or the setup directory could be written that sounds like a file/dir permission problem to me.
I’d recommend making sure the nginx user (www-data?) has permission to write.

Rebuild the site everything is working now.