MODx 3.0 RC2 Package Manager only showing "checking for updates" spinner

On a clean install of MODx 3.0 RC2, after downloading a bunch of common packages, and before anything is installed, the package manager then shows checking for updates … forever.

I was never able to get rid of that message so I wiped the site and reinstalled. Then I download/installed a few packages one at a time.

  1. Ace (worked)
  2. getResources (worked)
  3. Wayfinder (worked).
  4. MIGX - broke the package manager again and showed the “checking for updates” spinner.

I don’t know if there is something wrong with downloading MIGX (not even installing it) or if it was simply the 4th package.

Has anyone else had this problem?

1 Like

maybe try, if this one works for you
MIGX/ at master · Bruno17/MIGX (

1 Like

Uploading that seemed to fix the problem and package manager seems to be working again.

I had a test site with this problem too. In addition, the Manager home page returned an error.

This package fixed both issues :+1: