MODX 3.0.0 Error: Class 'Document Update Manager Controller' not found

Apologies if this is neither the time or the place to mention problems with the 3.0.0 release candidate, but after sorting the problem with the package manager yesterday, I now find I cannot change the template assigned to a resource. Every time I select a new template from the Uses Template drop down list on the resource page, I get a big red box with the following error and the template is not changed:

Error: Class 'DocumentUpdateManagerController' not found


* ResourceManagerController::getInstance(object, string "DocumentUpdateManagerController", Array ( [namespace] => core [namespace_path] => /home/yamac/public_html/manager/ [action] => resource/update [controller] => resource/update ) )
* MODX\Revolution\modManagerResponse->outputContent(Array ( ) )
* MODX\Revolution\modManagerRequest->prepareResponse()
* MODX\Revolution\modManagerRequest->handleRequest()

Perhaps the best thing is to try to roll the site back to 2.8.3. Tried yesterday to do that without success, and so pressed on with 3.0.0 after Mark very kindly solved the package manager problem, but maybe the roll back is the way to go.

That has been fixed in rc2 which is planned for release this week. See relevant issue on GitHub.

Applying the patch should only take a minute and be a lot faster than a rollback. :wink:

1 Like

Thanks again.

“The topic has been solved. Only reply if…” But I want to say that for chaps on distant hillsides with dodgy satellite connections, being tossed between backend error logs and blank screens on the front end with the dreaded “500 server error” message, feeling that Munch had no idea whatsoever how deep the existential Horror could become, this forum is - quite literally - a lifesaver.

Thank you again.

I wouldn’t mind being on a distant hillside :wink: Glad I can help and thank you for trying MODX3.

1 Like

This topic was automatically closed 2 days after discussion ended and a solution was marked. New replies are no longer allowed. You can open a new topic by clicking the link icon below the original post or solution and selecting “+ New Topic”.