Missing resources after Gitify Build

Hi guys, I have the following resource inside my _data folder, this files is generated with Gitify extract:

id: 45
pagetitle: ‘Take The Level 2 Exam’
alias: take-the-exam-lvl2
published: 1
parent: 42
introtext: ‘’
template: 4
searchable: 0
createdby: 188
createdon: 1616516936
hidemenu: 1
uri: take-the-exam-lvl2.html
properties: ‘{“stercseo”:{“index”:“0”,“follow”:“0”,“sitemap”:“1”,“priority”:“0.5”,“changefreq”:“monthly”}}’
backgroundImage: ‘’
faq: ‘’
faqLink: ‘’
ligthboxes: ‘’
privacyPolicy: ‘’

Congratulations, you have finished the course! You can now take the Ofqual certified exam to receive your official qualification.  

What you need to take the exam:

This online 90 minute test will be administrated externally Confederation of Tourism and Hospitality (CTH) under secure examination conditions and invigilated remotely using the camera in your computer or laptop. 

You will need the following:

  • A computer or laptop with a working webcam – tablets or smartphones arenot  
  • An internet connection with a minimum upload speed of 1MB/sec.
  • Google Chrome internet browser.
  • A formal, government ID with photo identification as per the terms and conditions

What happens after the exam:

After the exam, your pre-released result will appear on a final screen. This result and your exam will then be sent to be moderated and confirmed - a process which takes approximately two weeks. After this, you will be sent a confirmation of your final, approved result and a digital certificate will be emailed to the email address you have used to complete the course and book the exam. Your certificate will have a unique number for reference on the CTH database.

You need to score 60% or above to pass the exam. If you do not pass, you do have the option to re-take the exam. You will be prompted when you return to our site to pay for a re-examination at a cost of £51.60 including VAT.

What happens now:

When you are ready to take the exam, press the ‘Apply for the exam’ button below to inform the Examination Awarding Body. They will then send you an email with further details of how to take the test to the email address you have registered to complete the course. Please check your inbox and spam.  Once you have scheduled your exam, you have 48 hours to take it.

Good luck.

When I run Gitify build -f -vvv, I can see the following on my log - Created new resource from uri: take-the-exam-lvl2.html yet, when I check the database or the manager, the resource isn’t there, what could I be missing? I already tried installing my site from scratch, yet the resource won’t appear

I wonder if this is being caused by something that could be picked up by @bobray 's Site Check?

1 Like

thanks a lot, will check on that, we are finishing standardizing a spaghetti site, and it makes total sense that something could be broken inside and causing these issues.

Perhaps a different resource in the gitify data has the same ID because of a merge from different environments, causing the Gitify build to later update the resource it had created to give it a different name. Tried accessing it by its ID in the manager to see what’s there? /manager/?a=resource/update&id=45

It’s useful to do an extra (non-force) build and extract after a merge and before deploying to another environment, to ensure the data matches the db. Gitify does some ID conflict resolution but that’s fairly basic and will not catch everything properly.

1 Like

Thanks a lot, this was the trick that ended up fixing the problem…the core issue was that someone in the team messed up a merge and the _data files were inconsistent