Managing Quip comments

I have just installed Quip 2.3.5-pl on MODX Revolution 2.8.1-pl. I am the website super user.

I run a test using

[[!Quip? &thread=`threadNameHere` &threading=`0` &useGravatar=`0`]]
<br />
[[!QuipReply? &thread=`threadNameHere`]]

Comments entered from front end is saved and displayed as expected. However, I am not able to view the comments in Quip manager in the backend. So I am not able to delete any unwanted comments.

I have tried to follow instructions from to no avail

I’m also not able to find the QuipComment and QuipReply templates which I would like to slightly modify.

The templates are located as files under core/components/quip/elements/chunks.

  • quipcomment.chunk.tpl
  • quipaddcomment.chunk.tpl

Copy their content into a chunk and provide them as a property to the snippet calls.

[[!Quip? &thread=`myThread` &threading=`0` &useGravatar=`0` &tplComment=`myComment`]]
<br />
[[!QuipReply? &thread=`myThread` &tplAddComment=`myReply`]]

There should be a menu item in the top menu under Extras -> Quip to manage the comments.

HI halftrainedharry

Thanks for your response. I have found the templates. Also worth noting that new chunk in the element tab.

I knew about Extras -> Quip. Problem is that went I go there there is no data displayed eventhough I have already created some dummy comments


When you open the Network-Tab of the developer tools of your browser and then click the “Clear Filter”-Button. Do you see the AJAX-request that is sent (with the action “mgr/thread/getList”)? Is this request successful? Does it return something?

The request should return the entries of the database table “modx_quip_threads”. Are there any rows in this table?

There is usually an PHP error file (outside of MODx) where more information about server errors should be logged. The location of this file depends on your hosting provider. You should take a look at this file.

Got this back from the host

Thank you for contacting support . We have checked and could see that the script index.php is causing the issue on the internal server error within the website. Unfortuantely we do not support on scripts or coded sites, so we request you to contact any website developer as they can check and update it for you

Well, this doesn’t help. Without a specific error message it is hard to say what exactly causes the error.
Don’t you have access to this error file yourself?
This post lists common locations for such an error file:

Unsolicited suggestion: ditch your host immediately if they blankly refuse to point you in the direction of an error log. Wow.

I did a complete reinstall of modx and the extras. On installing quip I got the following message

Attempting to install package with signature: quip-2.3.5-pl
Package found…now preparing to install.
Grabbing package workspace…
Workspace environment initiated, now installing package…

modAction support is deprecated since version 2.3.0. Support for modAction has been replaced with routing based on a namespace and action name. Please update the extra with the namespace quip to the routing based system

Successfully installed package quip-2.3.5-pl

How do I “update the extra with the namespace quip to the routing based system”

Despite this deprecation notice, the extra should still work with the current version of MODx.
In my local test environment (MODx 2.8.1, Quip 2.3.5, PHP 7.2.14) I don’t have those server errors.

The “Please update the extra…” part is addressed to the developer of the extra. Unless you are a developer and can contribute on github, you have to wait until someone else makes the necessary changes to the code.

Did the reinstallation have any effect? Does it work now?

Still not working despite the reinstall. Running same versions of modx and quip as you. web server running php 7.3.6.

Is there any permission that needs changing after installing the extras

I am having the same problem with galley and there seem to be something common, an uncaught error

Uncaught TypeError: this.mask.addClass is not a function

ExtJS 3
ExtJS 3
setInterval handlern
ExtJS 2
setTimeout handler
ExtJS 2
ExtJS 2

No, and insufficient permissions wouldn’t result in a 500 internal server error.

Not sure that these errors are connected. This error log looks similar to the problem in this thread, where the problem was mod_security.

Are you suggesting that some columns in the database need to be changed?

Instead of speculating for days, what the cause of the error could be, it would really help if you could look at the PHP error log. The messages there should clear things up.

Maybe you could also check that the file permissions on the server are correct.

Hi Guys,

Thanks for your efforts but since that I still haven’t solve this issue I am going to put it on the back burner for now. The comments are appearing on the website and I need to work on other parts of the site.

Let me know if I need to award points for proposed solutions or level of assistance provided in trying to work this out.