Login-Extra in modx3 not working. Remedy?

Hello Forum,

the Extra “Login” seems to be broken in Modx3 (3.0.1-pl).

(PHP throws this error: PHP Fatal error: require_once(): Failed opening required ‘/path/to/core/model/modx/processors/security/login.class.php’ in /path/to/core/components/login/processors/customlogin.class.php on line 28)

I just need users to be able to login on and for the web context in frontend. No registration or anything else but logout would be nice.

Until now I just used the Login-Extra for this job and didn’t think any further, but now it’s not available.

I wonder: Do I miss something? Maybe a different Extra or method for that job in modx3?

And - isn’t everything theoretically needed already built in? (i.e. how does it the manager-login)

Is there a workaround to make one’s own form and handle the authentification in a custom snippet that leverages built in objects? Am I thinking too complicated or too simple?

Fast help with ideas greatly appreciated.

Hi @domindian

I have MODX3 sites running Login successfully.

These sites were upgraded from MODX 2.8 and I never had any issues with Login.

At what point is the PHP error thrown? During user login?

Thank you for your answer!
Yes, the error is thrown during the attempt to login.

https://sitedash.app/extras shows no info about compatibility of that extra…

The issue is with a fresh install of modx3.

Do you have the property loginViaEmail set to 1?
Try setting it to 0. It seems like there is a part of the code that hasn’t been changed to be compatible with MODX 3.

1 Like

Hello halftrainedharry,

thank you, you absolutely hit the bullseye. Thank you!

The property &loginViaEmail=true was actually set and without it works. I am a bit ashamed I didn’t trial that before.

So it’s only half broken at the moment ^-^. I can handle the usernames differently for now.

Thank you very much.

1 Like

If you need the loginViaEmail functionality, delete line 28 (require_once ...)

and change line 30 to

class CustomLoginProcessor extends \MODX\Revolution\Processors\Security\Login {

Thank you, I’ll try that!