MODX Community

Issues moving site to a new domain (with new directory and database)

I want to clone a site to a different location with its own database. Basically I would think the general “moving a site” things would apply here.

So I have

  • logged out all users
  • cleared the cache via the manager and manually deleted it
  • copied the files to the new location
  • copied the database
  • changed the config file to match the new database, user, paths, etc
  • changed the other config files to point to the new core directory
  • tried to rerun the setup, BUT

Whenever I run the setup with the “Upgrade Exisitng Install” option, I get the old file path directories from the original site.

Whenever I run the setup with the “Advanced Upgrade Install” option, I get this error:
Checking database: Table prefix does not exist in this database!
My table prefix is set correctly though as far as I’m aware. It’s vn_ which is exactly like it shows before every table in there.

So basically I can’t run the setup in any way, but I really would like to, to ensure the move was clean. Any suggestions?

1 Like

That sounds like the core/config/config.inc.php file is not fully updated yet. You can try clearing the cache again (if you hadn’t yet since the move) to make sure nothing’s cached there.

1 Like

I have cleared the core/cache multiple times, even tried different browsers, just in case it’s cached somewhere there without success…

I just downloaded the original MODX installer again and used the setup from that folder, as I previously used the setup folder from the original install (which I moved outside the accessible parts ofc). That worked now, so it seems like somehow the setup folder is changed during install? Anyway, working fine now, thanks for the help!