MODX Community

Imgrate Live to Local

I want to migrate my live website to my local wamp server so i can make changes to my website first on the local before going live Here are the steps I’ve done:

Made a duplicate of the database and added it to MySQL on the WAMP
Made a duplicate of the website and transfered it across - Cleare the cache first and logged out before duplicated
Changed the .htaccess file
Changed the config.core file x 3
Changed the config.inc file to pick up on the new database in the local MySQL
Changed the Paths in the config.inc file
Changed the Site URL in the database to pick up the CSS and JS files

I can see the frontend and log into the backend but resources tree isn’t visible, the news and security feeds just keep loading and the navigation about links to nothing but empty pages.

Has anyone come across this before?

Have you tried rerunning the /setup after moving everything?

So I just download a new MODX Revo and only transfer across the setup file?

Yes, just make sure you use the same MODX version.

As a side note: I tend to keep my setup folder stored with a backup. You don’t want to have it public of course, but keeping it offline or inaccessible for cases like this comes in handy sometimes.

you will need the whole setup-folder, not only the file

I brought over the full setup folder and ran it. I got 2 Success Messages and No Toggle Warnings. I logged in but still no joy.

Success Messages:

  • Config file successfully written.
  • Config file permissions successfully updated.

Got it sorted. Went through the folders in manager one by one. Noticed a few files missing and transferred them across from a new download. Fixed my issue.

Thank you all for your patience. I can’t still say I’m new to this as this is my 4th year working with it BUT I’m still learning :slight_smile:

1 Like

Glad you worked it out! :blush:

Just for reference and maybe other people having the same issue in the future, do you mind sharing which files were missing?

Yes indeed…

It was the manager/assets/ext3 files that were corrupt and missing key components. I just downloaded the appropreiate Modx Revo and transferred across a new ext3 folder and it fixed the issue.