How to make sure [[++manager_url]] return https

Good day,

I have a web site which give some trouble.
It’s look like an css file can not be loaded.

I look at Firefox, and I have this error

Blocked loading mixed active content “

and in my template, I have this

<link href="[[++manager_url]]templates/awen/js/slide-menu/dist/slide-menu.css" rel="stylesheet">

I can understand that [[++manager_url]] return http instead of https.

How can change this?

Thanks a lot

Usually [[++manager_url]] has just the value /manager/ with no domain or protocol.

If you just output [[++manager_url]] on your page, what is the value? Maybe the wrong protocol comes from the <base href="" /> tag in the <head>?

hello, Thanks for your reply.

For base tag, I have this

<base href="[[!++site_url]]">

I look at the settings and I searched for site_url, and I was surprised that nothing related to site_url was showed

I believe those basic settings are defined in the config file core/config/

Is your server_protocol System Setting set to https?

Also, make sure you don’t have any hard-coded http links (e.g., image links) on any pages.

Haven’t we established that this setting does nothing at all?

That’s news to me. :wink:

I always force https in .htaccess, so I haven’t paid much attention to the System Settings on this.