Collections not displaying their children in manager

Im not able to Edit the Childs of a Collection, due those arn’t displayed if i click on a collection in the Resource tree.

I get an JavaScript error, like the following:

Uncaught TypeError: b[(d.xtype || e)] is not a constructor
    at Object.create (ext-all.js:21)
    at collections.panel.Category.createComponent (ext-all.js:21)
    at collections.panel.Category.lookupComponent (ext-all.js:21)
    at collections.panel.Category.add (ext-all.js:21)
    at collections.panel.Category.<anonymous> (ext-all.js:21)
    at Object.each (ext-base.js:21)
    at collections.panel.Category.add (ext-all.js:21)
    at collections.panel.Category.initComponent (ext-all.js:21)
    at collections.panel.Category.initComponent (ext-all.js:21)
    at collections.panel.Category.initComponent (ext-all.js:21)

I had moved the Website to our inhouse server to upgrade MODx and to edit the website.
I havn’t encountered any problems on the server, the website and the manager are working perfectly fine.

I have cleared the cache and logged out all users before i moved the Website.

The Website was running on MODx 2.5.2 and i upgraded it to 2.5.7, i also updated all extensions without any problems.

Server environment:
Inhouse Server:

  • PHP 7.3.8
  • MySQL 5.0.12
  • Apache 2.4.18

Costumer Server:

  • PHP 7.3.10
  • MySQL 5.0.12
  • Apache 2.4.18

I have tested it with the following Browser:

  • Chrome 77.0.3865.120, (Also Incognito)
  • Safari
  • FireFox 66.0.3

What i have tried so far:

  • Cleared MODx Cache
    Via Manager, and FTP removed the contents of the cache folder
  • Disabled Compressed_JS and Compressed_CSS
  • Rerun the Setup of MODx 2.5.7
  • Multiple times reimported the MySQL DB from our local server to the customer server
  • disabled all PHP Error reportings
  • double checked the core config paths, base url, htaccess settings

I have looked through some troubleshooting i could find, but sadly those didn’t solve my issue.

I didnt want to uninstall the Collection extension, as it would spit out all Collection children as documents and wont gather them in a collection if i reinstall the extension.

If you need any further information, dont hesitate to ask me :slight_smile:

I would be glad if anyone can help me solve this issue. ^^

If you uninstall the extra it will be separate children, but as soon as you installed the extra again ant put the parent to collection, it’s all good. I think that reinstalling the extra will do the trick.

Thanks for your advice, i didnt know that if i just change the parent back to a collection, that it will be put back together.
I tried the solution, sadly it didnt solved my Issue.
I also cleared the cache after uninstalling the extra.

Do you have more issues regarding manager views? Can you see the rest of your pages correctly?

It seems only the view of collections wont show, i can edit all other pages like documents or weblinks, also im able to edit templates and chunks.
Everything works fine as far as i have checked the manager.

Hmm… weird. When you uninstalled the extra, did you remove all packages? Did you checked on the server?

Last thing I can think of is to manually download the extra, upload it and then install trough manager.

Thank you for your advice.
To be honest, i haven’t experimented that much with packages at all, i didnt know how they were installed or even located in MODx at all.

With your advice i figured out that those packages were saved under core/packages and i had multiple versions of the Collection package installed, i guess it happens when you update a package via the Package manager.

The Issue was that the newest version of the Collection package was somehow incompatible with our existing collection documents we created.
I had to manually install an older version like Collections 3.5.0 which seems to work properly as expected.

I thank you for given the Hint that it has to be the Package which causes the issue.
I was looking at the Apache Server configuration and stuff, but never thought that it has to be the Package.

For everyone looking for a Solution:

  1. Uninstall the Collection Extra via the Package-Manager

  2. Delete the Package (you might forcefully delete the package)

  3. If it seems the package didnt delete, look at the version number, it might be an older version which is still installed.

  4. Test if this older version might work
    a. Change the Resource which was a collection back to a collection under the Settings tab.
    b. Every child should be gathered back to the collection.

  5. If it didn’t help, repeat the first steps until you have no versions left installed.

  6. Check this page for older releases of the package and manually install them and try again.
    a. Upload the (xxx - Version number) into the folder “core/packages”.
    b. Back in the MODx manager goto the Package Manager, the button Download Extras has an arrow on the right side, there you can choose to search localy for packages
    c. The package should be listed in the grid, now install it and try it again.

1 Like