Blank Manager with undefined message and unfunctional navigation


My website manager is not working properly.
Whenever I login into the manager I do not see any content. Everything is blank except for the not functional navigation, an “undefined” message and two empty tables(online users, recently edited).

Things I have tried

  1. Using different browsers (Google Chrome, Firefox, Microsoft Edge).
  2. Logging in via incognito browser.
  3. Enabling Javascript in the site-settings
  4. Changing the value of compress_js and compress_css to 0 inside of the database.
  5. Browsing to
  6. Browsing to instead of
  7. Clearing the browser cache.
  8. Clearing the filesystem cache.

Good to know:
My current MODX version: 2.3.5-pl
In my console of the website I have multiple errors

My SSL certificate works on the website while not logged in. But it does not work inside of the manager.

Thank you for reading this and I hope I will hear from you.

I looks like you’ve tried a lot of the right things.

Have you edited or updated anything significant lately (e.g., updating extras, modifying .htaccess, implementing SSL)?

Do you have hard-coded non-https links on the site.

Take a look at the MODX error log file (core/cache/logs).

Turn on Dev. Tools (F12 or Ctrl-shift-i) and watch the network tab as you try to access the Manager. Look for 404s or timeouts.

Have you edited or updated any extras that use JavaScript in the Manager? It looks like some JS is either not loading, and/or has a syntax error. Not loading might be because of an http/https issue. Be sure the server_protocol System Setting is set to https if you’re using SSL. You may also have to rewrite http requests to https in .htaccess.

Your version of MODX is quite old. It was released in June of 2015. It’s possible that your version no longer plays nice with current software (e.g., PHP 7)

Do you have a htaccess file in the manager directory and if so can you show the contents here?

My first advice would be upgrade asap and try again.

1 Like

not sure, if this is related

he was also talking about an ‘undefined’ message

Hello and thank you for your response,

Yes I do have a “ht.access” file in the manager directory.
The contents are:

RewriteEngine Off

Could it be a problem that the file is named “ht.acess” instead of “.htacess”?

Thank you,

Yours sincerely,


Not necessarily. It’s going to depend what you have in your root htaccess file. Problem is you’ve also fallen behind with your MODX version - should be at least 2.6.5 to take account of security issues. In newer versions of MODX there are a few lines (in the root htaccess) that will allow you to redirect / effectively force https in the manager BUT I’m not saying this is your problem.

Are you running the Gallery extra? If so, can you see if an upgrade is available for that?

Also see the thread that Bruno has highlighted above.

My main concern as ilja-web mentions above, would be to get upgraded.

Hello Bob, thank you for your response,

There has not been any significant updates/changes lately… Not in the website nor in de database. There are also no hard-coded non-https links on the site.

There were multiple errors. Which are stated below
(I have replaced my domain name and my database name for privacy reasons).

  • [2021-03-25 22:18:49] (ERROR @ /home/MYDATABASENAME/domains/ : 149) Could not find action file at: /home/MYDATABASENAME/domains/

I decided to check the path location and indeed. The file does not exist.

[2021-03-25 22:19:06] (ERROR @ /home/MYDATABASENAME/domains/ : 149) Could not find action file at: /home/MYDATABASENAME/domains/

I decided to check the path location and indeed. The file also does not exist.

[2021-03-25 22:19:16] (ERROR @ /home/MYDATABASENAME/domains/ : 149) Could not find action file at: /home/MYDATABASENAME/domains/

I decided to check the path location and indeed. The file also does not exist.

[2021-03-25 22:19:39] (ERROR @ /home/MYDATABASENAME/domains/ : 149) Could not find action file at: /home/MYDATABASENAME/domains/

This file actually exists!

I have looked into the network tab and I came across one 404 error.
I noticed that the path of the s.gif is incorrect. The assets folder is named undefinedassets.

I also have a 301 and a 302 error which I think is worth mentioning since they both have something to do with the manager. I tried sending the two screenshots but since I am a new user on this forum I am unable to do that. And I will do that in replies.

After I setup an http to https redirect in my public_html .htaccess (and having server_protocal set to https) I received this error whenever I try to access the manager site by The normal site still works whenever I had applied this change.
This is the error I got:
This page does not work. Too many redirects.(if translated correctly from Dutch to English).
I wish I could send this as an image but I cannot send more images here since I am a new user on the MODX forums since I made this account specifically for this issue.

I have not edited or updated any extras that use JavaScript in the manager.
The value server_protocol inside of the database was already set to https.

Also mentionable notes:
In Juli 2020 has my old version of MODX been patched by a renowed company to a high security level because the site is still being used with php 5.x(the server also runs on php 5.x). After this patching the website and the manager still worked.

Inside of the manager, while my navigations do not work, I am still able to access “Components” -> “Quip, Slideshow manager, and Gallery”. The component installer does not work. These are the only accessable items in the navigation.

I hope this gives enough information.

Thank you.
I would love to hear back from you,

Yours sincerely,


Hello and thank you for your response.

I have followed this forum post and I have looked into the recommended steps.
The recommended steps have not worked for me but I keep looking for answer in that forum to keep trying since I really want to solve this issue.

Thank you,

Yours sincerely,


Hello and thank you for your response,

The gallery extra is not used in the website. Which I can do… Is access the gallery component inside of the navigation. While I cannot open any other navigation-links(except other components(except installer)).
Thank you. I am aware of the fact that the MODX version used on the website is not up-to-date and I have read(and keep following) the thread that Bruno has highlighted, but untill now there has not been a solution to my problem.

Yours sincerely,


I usually don’t recommend upgrading a non-working site, but in your case I think it might be a good idea to upgrade both PHP (to PHP 7) and MODX to 2.8.1-pl).

The error log messages suggest that either you have a problem with either a dashboard widget or a plugin.

You can disable plugins in the modx_site_plugins table. Put a 1 in the disabled field.

You can remove all widgets by emptying (truncating) the modx_dashboard_widget_placement table in the DB. That won’t delete any widgets, but it will remove them from all dashboards so their code won’t execute.

Manually clear the cache after the above before testing.

BTW, you have tried repairing the DB tables in PhpMyAdmin, right?

Hello Bob Ray,

I don’t think upgrading the website is an option since the website is getting used daily by customers.
My idea is to make a testing environment where I could try all other “dangerous” possible fixes.
Disabling the plugins might work indeed. I will try that whenever I get the time to do that, the same for removing the widgets.

Thank you for your response,

Yours sincerely,


Hello Bob Ray,

I am afraid to try this since the website is still up and running and it gets used daily by customers.
I will try this after setting up a testing environment.

Thank you for your response,

Yours sincerely,


Yes, it’s possible for an upgrade to cause errors that you need to resolve.

However I’d be much more concerned about getting hacked, you’re missing so many security fixes (some rather critical ones) since 2.3.5-pl (almost 6 years old!!!) that it’s a miracle your site hasn’t already been hacked. It’s also entirely possible the site has already has been compromised, but you’ve just not noticed it yet.

What’s worse, that the site is unavailable for a few hours because you’re performing way overdue maintenance, or that your site is compromised, serves up malware, and actually infects your daily customers?

I understand wanting to first run upgrades on a staging environment, but you really need to start doing that right away. Don’t wait with that. Hire someone who has more experience if you’re not comfortable with the process or debugging issues, but don’t delay getting your production site upgraded. Especially because of those daily users.

+1 for what markh said.

one more thing to try, i’ve had this happen to clients also

I’ve found that if you login to the manager (blank pages happen)

add (www) and that usually fixes it

Hello rcarnick,

Thank you for your response!

Sadly this is something I have tried. It did not work.

Thank you very much either way!

Yours sincerely,


Hello Mark,

The site is actually not as critical as it seems. The site got upgraded last year to the highest level of security by a trusted MODX developer.
I understand that updating is necessary and it MIGHT be the solution to this problem. Although if this does not solve the problem I feel like the problem will grow.
Therefore I want to test it on a testing environment first and if that is successfull I will execute it on the live website.

Let’s hope it works!

I will keep updating this forum untill the problem is fixed. Thank you for your response.

Yours sincerely,


Respectfully, a site that hasn’t had its core system updated in 6 years does not for a moment deserve the label of being “upgraded to the highest level of security”. Staying up to date is security 101, everything else one might do to harden security or add additional measures all depends on getting the basics right.

I appreciate you understand the seriousness of performing the upgrade ASAP and I also do not mean to shame you or whoever did the work for you, but I truly must emphasize that if someone claimed to have “upgraded to the highest level of security” without upgrading the core, they did not do their job.

If whoever did that work for you stands firm that they believe your site is safe, please send them my way. I’d love to hear how they believe they can pull that off. Sounds like quite the trick I’d love to apply to my sites, too! :wink:

1 Like