"Article container" page is not loading

Can anyone help me to solve this problem. All the pages are loading except “Article-container”. I am using default “article-container” template

Article Container page URL:

This redirecting error is weird. It’s seems that the page is redirecting to itself over and over again.

Make sure that the system setting error_page (and maybe unauthorized_page) are set correctly.
Have you tried using a different alias for the “Articles Container” page?
Are there any plugins that run on the event “OnPageNotFound”? Maybe (temporarily) deactivate them.

What PHP version are you using?
Are there any (relevant) errors in the MODX error log?

Yes, I have tried different Alias. And I don’t know the PHP version.
Is this error effecting?
How to solve this?

In the manager, go to “Manage” → “Reports” → “System Info” and in the row “phpinfo():” click on “view”.

This is just a warning. And the controller is only used in the manager and not on the frontend.

Something on the page must cause a redirect.
Have you tried using an empty template for the container page? Can you view the page then?
Is there something special in the .htaccess file?

PHP Version: 8.0.26
Yes, I tried using empty template for the container page. But still problem.
.htaccess file

When you temporarily delete the content of the “Articles Container”, does it work then?

No. It doesn’t work even

So you have a an empty template and and empty content and you still can’t view the page? And all other pages work correctly?!

Have you tried deactivating the plugins that run on OnPageNotFound? For example the “ArticlesPlugin”?

What’s the content of the system setting articles.container_ids?

I have uninstalled the plugin but still showing container in menu when I visit the site url.
Now “Home” is a container. And It doesn’t show the error.

What do you mean by that? Did you uninstall the extra “Articles”? Or did you delete the plugin with the name “ArticlesPlugin”? I’m confused.

What do you mean by that?
Has the page “Home” just the “Container” flag set (class_key= MODX\Revolution\modDocument but isfolder = 1) or is it a “Articles-container” (class_key= Articles\Model\ArticlesContainer)?

  • Sorry that was misunderstanding. I removed the “Articles” extra.
  • I tried by removing “OnPageNotFound” but still it shows same problem.
        $router = new ArticlesRouter($modx);

But one thing I noticed if I uncheck the “container” everything works fine.