All Migx on site are not displaying in manager

The MIGx are not displaying in the manager and can not be edited. I think it’s a Smarty error but I can’t be sure. I made a test migx with the config from the modx documentation and it still doesn’t display. There is one JS error when viewing a resource with a migx.

This is what i see in the manager.

This is the error in the console.

This is where the error occurred.

Any help would be much appreciated.

MODX Version 2.8.4
PHP Version 7.4
MIGX Version 3.0.0-alpha5

I think the problem is, that this line in the smarty template

gets converted to this.parent_window = '<?php echo $_REQUEST['window_id'];?>'; and this generates a notice on your server (when the request parameter doesn’t exist) that breaks the output.

You could try to change the error_reporting on your server to exclude notices or maybe try changing the line above to this instead:

1 Like

Thank you that worked, I also found that changing the quotes to backticks on that line in migx.tpl also works because it allows for multiline strings.

This topic was automatically closed 2 days after discussion ended and a solution was marked. New replies are no longer allowed. You can open a new topic by clicking the link icon below the original post or solution and selecting “+ New Topic”.