Access denied after upgrade to 2.8.3


I’ve just upgraded MODX to 2.8.3 and PHP to 7.4.
Since then, I cannot saved any resources even with full admin privileges.

What I’ve already done :

I’ve double checked this article but in vain :

Disable some old plugins, just to test purpose

Clear cache, flush all …

In Safari, I’ve got a popup Access denied. In Chrome, only errors in console :
Uncaught TypeError: m.fireFn.apply is not a function

Any idea ?

Thanks in advance for your help.

This looks like a compress_js issue. You can disable this setting temporary quite easy without direct database access.

Edit the file


and search for

'compress_js' => '1',

and change it to

'compress_js' => '0',

and save the file.

After you can enter the backend again. It is very important that you change the real MODX system setting compress_js too, since the cache is deleted quite often. So go directly to your system settings, search for “compress” and disable compress_js.


Thanks for your advice but compress_js is already set to 0 or no both in cache and system settings.
The issue does not seem to be related.
Any thing else to try ?

Thanks for your help.

Does the rest of the manager still work?

When you open the “Network” tab of the developer tools of your browser and then save the resource, is there an error message in the response of the request?

Have you tried deleting everything under core/cache/? Have you checked to see if the php user got changed during the upgrade?

Have you tried visiting with your browser in incognito or private mode to make sure it’s not a browser cache issue. Sometimes a leftover cookie will cause trouble after an upgrade.

Having tried deleting everything in core/cache folder or use browser in incognito mode.

No issue shown in “Network tab”, except a SameSite cookie issue shown in console.
Could it be related ?

Thanks for all your help.

Do you run ModSecurity (a firewall) on your server? Maybe it’s blocking the request.

What is this issue? Just a warning?

What version of MODX were you on before? Are you running TinyMCE? Did you check /core/cache/logs/error.log to see if there were any entries?

I finally found out what was causing all these issue thanks to your help.
Actually, it was a too small max_input_vars set to 15 that was in cause.
Just setting max_input_vars to 1500 was solving the issue.
The migration to php7.4-fpm just happened to be unsucessful at first.

You helped me a lot.

This topic was automatically closed 2 days after discussion ended and a solution was marked. New replies are no longer allowed. You can open a new topic by clicking the link icon below the original post or solution and selecting “+ New Topic”.