3.0.2 Resources not showing in tree

I found a mention of a possible bug with the collections extra causing resources to not be visible in the context tree in the manager, and I seem to be having that. I installed several extras and then realized my resources were all missing. I also installed GoodNews, which failed with errors and could not be removed properly, but I found no mention of other instances of that. Any idea how to fix the visibility of my resources?

This is from the Collections Docs:

Collections is a MODX Revolution Extra that adds a custom CollectionContainer resource class with the following behaviour:

  1. Any direct child resource will be hidden from the Resource Tree in the Manager, and listed in a grid view (similar to Articles) under a dedicated “Children” tab.

I don’t use Collections, but if you uninstall it, the resources may show up again. You could also try going into the modx_site_content table in the DB and changing the show_in_tree field of each resource.

Unfortunately I have already uninstalled it, and nothing is hidden based on values in that database table. Everything looks like it should be visible.

GoodNews is not yet ready for MODX 3.x

Make sure it’s uninstalled - then check the System Setting extension_packages

Remove GoodNews from there if it’s present.

That fixed it, once I removed it from the extension_packages setting my resources returned.

1 Like

Glad you got it sorted :+1:

Could you add an issue here saying that Collections did not remove itself from the extention_packages System Setting when uninstalled?

It also must have left some files behind, or it wouldn’t have hidden the resources, unless you didn’t clear the cache completely.

Look in core/components/collections and assets/components/collections for any remaining files.

This topic was automatically closed 2 days after discussion ended and a solution was marked. New replies are no longer allowed. You can open a new topic by clicking the link icon below the original post or solution and selecting “+ New Topic”.